Avoiding the Top 10 NGINX Configuration Mistakes
We help you avoid the 10 most common NGINX configuration errors, explaining the problems caused by each and how to fix them. Errors include insufficient file descriptors per worker, disabling proxy buffering, and not using upstream groups and keepalive connections.
Excessive Health Service Discovery Not Enough File Descriptors Not Enabling Keepalive Connections Forgetting How Directive Inheritance Improper Use
Source: nginx.com